Weird centering problem (only in viewer) after runtime and compiler upgrade of our CR application

    Not sure how to describe this properly.  We are running a .NET 4.0 web based application that is very CR heavy.  We have about 300+ CRs that had been designed in CR 2011.  The .net based application passes the parameters, datasource and other pertinent information to the CrystalReportViewer Object within the code and performs a databind on this.  The CR engine more/less generates the report.

    We recently performed a CR runtime upgrade from version 14 to version 16.  We also upgraded from VS 2010 to VS 2015.  We made absolutely no code changes to the underlying application.  We recompiled the application utilizing the new CR runtimes and new VS2015.  The application runs and works perfectly, however of our 300+ or so CR that have been built in the past, around 10% seem to have centering issues.

    That is, the heading in the report is shifted far to the left.  I open the report up in CR 2011 and verify the heading is dead center.  I extend the box to the entire width of the page in designer and justify it center and resave, same issue.  I even have tried changing printers and upgrading reports to CR 2013 and the reports display the same.  It also appears if you attempt to print the report, it looks perfect????  However, the centering error is appearing on the viewer ONLY….  It appears the viewer is not RESPECTING ANY JUSTIFICATION SETTING ON ANY OBJECT THAT IS SET BY DESIGNER.

    It is not every report just some reports.  I’m lost as to what the differences are between reports.  I have several reports where the report was pretty much duplicated and resaved to make another report, one of these work fine, while the other has the issue? 

    It seems the only way to fix this is to carefully and physically move the object almost to the right of the page in designer, at which point it will appear centered in viewer, but will print right justified?

    I’ve used the C++ application made by Don Williams to analyze these reports.  I’ve also changed printer drivers etc????

    Not sure what’s going on, if someone can provide some help…..

    Not sure how to describe this properly.  We are running a .NET 4.0 web based application that is very CR heavy.  We have about 300+ CRs that had been designed in CR 2011.  The .net based application passes the parameters, datasource and other pertinent information to the CrystalReportViewer Object within the code and performs a databind on this.  The CR engine more/less generates the report.We recently performed a CR runtime upgrade from version 14 to version 16.  We also upgraded from VS 2010 to VS 2015.  We made absolutely no code changes to the underlying application.  We recompiled the application…

    Weird centering problem (only in viewer) after runtime and compiler upgrade of our CR application

    Very Helpfull

    User Rating: Be the first one !
    Add Comment
    1 Answer(s)

      Known issue, it’s been fixed in SP 17 due out end of May.

       

      Don

      Add Comment

        Known issue, it’s been fixed in SP 17 due out end of May.

         

        Don

        Add Comment

        Your Answer

        By posting your answer, you agree to the privacy policy and terms of service.