UI5 app not loading css libraries

Hi, I am working with webide and I am using BlockLayout. The Blocks are displayed just fine bue the property ‘Background’ doesn’t work.

The blocks are rendered on screen and the class sapUiBlockLayoutBackgroundMixed is added. However it doesn’t do anything. If I open the debug console the class doesn’t appear under the styles sections ( only .sapUiBlockLayoutSizeL .sapUiBlockHorizontalCellsRow, .sapUiBlockLayoutSizeXL .sapUiBlockHorizontalCellsRow, .sapUiBlockLayoutSizeM .sapUiBlockHorizontalCellsRow ).

These are the libraries I’m loading:

Any ideas ? thanks !

Hi, I am working with webide and I am using BlockLayout. The Blocks are displayed just fine bue the property 'Background' doesn't work. The blocks are rendered on screen and the class sapUiBlockLayoutBackgroundMixed is added. However it doesn't do anything. If I open the debug console the class doesn't appear under the styles sections ( only .sapUiBlockLayoutSizeL .sapUiBlockHorizontalCellsRow, .sapUiBlockLayoutSizeXL .sapUiBlockHorizontalCellsRow, .sapUiBlockLayoutSizeM .sapUiBlockHorizontalCellsRow ). These are the libraries I'm loading: Any ideas ? thanks !

UI5 app not loading css libraries

Very Helpfull

User Rating: Be the first one !
Train Asked on May 24, 2017 in SAP PORTAL.
Add Comment
1 Answer(s)

    Do an inspect element of the container on the chrome browser.

    Identify the exact element to check the actual classes being applied to the container.

    Now, modify the class in the styles to include the background property.

    It should work.

    Regards,

    Sharath

    Add Comment

    Your Answer

    By posting your answer, you agree to the privacy policy and terms of service.