Timesheet approval not open from UWL

92f661fe329c69e106b9ce5d86ef26d436d5fdd24b7f3562d8.png

HI,

We configured task TS31000007 for time sheet cats approval as attached,

But the work item displayed at UWL is calling webdynpro application called Catmanagerpprove not already exist in backend system,

Thanks for support.

Ramy

92f661fe329c69e106b9ce5d86ef26d436d5fdd24b7f3562d8.png HI, We configured task TS31000007 for time sheet cats approval as attached, But the work item displayed at UWL is calling webdynpro application called Catmanagerpprove not already exist in backend system, Thanks for support. Ramy 92f661fe329c69e106b9ce5d86ef26d436d5fdd24b7f3562d8.png (20.8 kB)

Timesheet approval not open from UWL

Very Helpfull

User Rating: Be the first one !
Train Asked on May 25, 2017 in SAP PORTAL.
Add Comment
3 Answer(s)

    Thanks Armando for your reply,

    I’m already re register every time tasks changed, my question is why this task generate workitem calls webdynpro application is not exist in the backend,

    “6WebDynproDeployableObject%3Dsap.com%2Fmss~cat~approval%26WebDynproApplication%3DCatManagerApprove& System=SAP_ECC_HumanResources&WebDynproDeployableObject=sap.com%2Fmss~cat~approval&WebDynproApplication=CatManagerApprove” Regards.

    Add Comment

      Hi Ramy

      Thanks for your updates.

      If Web Dynpro application CatManagerApprove from namespace sap.com is being launched, it’s because specific configuration has been made for TS31000007 in the XML file to launch it.

      As for why you don’t have such application in your system, it’s probably because you haven’t installed the corresponding portal business package which provides/installs it. From what I could check (as I’m UWL expert rather than MSS/ESS, I’m not 100% sure about it), the business package which installs the XML in UWL having the definitions of task type TS31000007 is the BPMSSADDON. Along with installing the XML, it should also install the iViews and web dynpro applications including the CatManagerApprove.

      Regards, Armando

      Add Comment

        Hi Ramy

        Eventually you’re missing the Re-registration of the connector.

        Could you ensure that you’ve clicked in the option Re-register (button) available for the UWL connector at the following place?

        System Administration –> System Configuration –> Universal Worklist & workflow –> Universal Worklist Administration

        Also, it might be worth to clear the UWL cache to ensure that we’re not affected by old cached data (from before the re-registration). Please check following SAP KBA for that: 2141647 – How to clear the UWL cache [VIDEO]

        Regards, Armando

        Add Comment

        Your Answer

        By posting your answer, you agree to the privacy policy and terms of service.