Error 1723 after upgrading InstallShield project to include 13.0.16 merge module

    I have an existing InstallShield (Basic MSI) project that has been working perfectly and included the version 13.0.8 (SAP Crystal Reports runtime engine for .NET Framework 4) merge module.

    I just recently downloaded the 13.0.16 merge module and upgraded my project to merge in this version instead of the 13.0.8. I confirmed when I built the project that it did merge in the newer version.

    The project built successfully, but when testing out running the resulting installer *.exe that I built on a dev machine, I get “Error 1723. There is a problem with this Windows Installer package. A DLL required for this install to complete could not be run. Contact your support personnel or package vendor. Action RemoveLink, entry: RemoveLink, library: C:\…\MSIAE45.tmp“.

    The primary thing that I changed in my project, which used to run successfully with the 13.0.8 version, was to upgrade this to 13.0.16. I also changed the Product Code and Package Code but left the Upgrade Code alone and the project is set up to upgrade previous versions with that Upgrade Code.

    I opened up the 13.0.16 merge module file in InstallShield and I see the RemoveLink custom action in there so I believe it has to do with the upgrade to 13.0.16. Am I missing any prerequisites that 13.0.16 requires?

    I looked for a list of prerequisites but I could not find any information on that.

    Please let me know if you need any more information on my set up.

    Thank you,

       – Mickie

    I have an existing InstallShield (Basic MSI) project that has been working perfectly and included the version 13.0.8 (SAP Crystal Reports runtime engine for .NET Framework 4) merge module. I just recently downloaded the 13.0.16 merge module and upgraded my project to merge in this version instead of the 13.0.8. I confirmed when I built the project that it did merge in the newer version.The project built successfully, but when testing out running the resulting installer *.exe that I built on a dev machine, I get "Error 1723. There is a problem with this Windows Installer package. A DLL required…

    Error 1723 after upgrading InstallShield project to include 13.0.16 merge module

    Very Helpfull

    User Rating: Be the first one !
    Add Comment
    1 Answer(s)

      At this time there are no new pre-requisites. That will come in a few months when we move away from VC++ 2005 dependencies.

       

       

       

      – Ludek

      Add Comment

        At this time there are no new pre-requisites. That will come in a few months when we move away from VC++ 2005 dependencies.

         

         

         

        – Ludek

        Add Comment

        Your Answer

        By posting your answer, you agree to the privacy policy and terms of service.