DUMP In OO ALV Report

    Hi All,

    Created an OO ALV.

    When User clicks on “Append Row” an blank row will be inserted. When user clicks on F4 and selects the data.

    Data is not inserted to row, instead changes the Column heading and dumps.

    Help required to avoid this.

    Below is the DUMP getting:

    Runtime Errors GETWA_NOT_ASSIGNED

    What happened?

    Error in the ABAP Application Program

    The current ABAP program “CL_GUI_ALV_GRID===============CP” had to be

    terminated because it has

    come across a statement that unfortunately cannot be executed.

    Error analysis

    You attempted to access an unassigned field symbol

    (data segment 32779).

    This error may occur if

    – You address a typed field symbol before it has been set with

    ASSIGN

    – You address a field symbol that pointed to the line of an

    internal table that was deleted

    – You address a field symbol that was previously reset using

    UNASSIGN or that pointed to a local field that no

    longer exists

    – You address a global function interface, although the

    respective function module is not active – that is, is

    not in the list of active calls. The list of active calls

    can be taken from this short dump.

    Hi All,Created an OO ALV.When User clicks on "Append Row" an blank row will be inserted. When user clicks on F4 and selects the data.Data is not inserted to row, instead changes the Column heading and dumps.Help required to avoid this.Below is the DUMP getting:Runtime Errors GETWA_NOT_ASSIGNEDWhat happened? Error in the ABAP Application Program The current ABAP program "CL_GUI_ALV_GRID===============CP" had to be terminated because it has come across a statement that unfortunately cannot be executed.Error analysis You attempted to access an unassigned field symbol (data segment 32779). This error may occur if - You address a typed field symbol before…

    DUMP In OO ALV Report

    Very Helpfull

    User Rating: Be the first one !
    Add Comment
    1 Answer(s)

      Hi,

       

      Please make sure that your not accessing any filed symbol without assigning.

      If you can provide the code where exactly it is giving dump… so that it will be easy to fix the issue.

       

      Please check the below links.

      http://sapabap-techsupport.blogspot.com/2010/09/how-to-implement-f4-search-help-in-oo.html

      F4 help — on editable alv field.

       

      Regards

      Aravind.

      Add Comment

        Hi,

         

        Please make sure that your not accessing any filed symbol without assigning.

        If you can provide the code where exactly it is giving dump… so that it will be easy to fix the issue.

         

        Please check the below links.

        http://sapabap-techsupport.blogspot.com/2010/09/how-to-implement-f4-search-help-in-oo.html

        F4 help — on editable alv field.

         

        Regards

        Aravind.

        Add Comment

        Your Answer

        By posting your answer, you agree to the privacy policy and terms of service.