Copy&Paste via JavaScript does not work any more in Netweaver Portal 7.5

We use a copy&paste function via JavaScript in a Bex WebTemplate. The functions

sapbi_rig_cp_copy_clipboard and sapbi_rig_cp_paste_clipboard are used. After migrating to netweaver 7.5 the copy&paste does not work any more in IE browser when we are in Portal context. It is still working when we execute the webtemplate directly. Does anyone have an idea about the reason for this behaviour or a solution?

We use a copy&paste function via JavaScript in a Bex WebTemplate. The functions sapbi_rig_cp_copy_clipboard and sapbi_rig_cp_paste_clipboard are used. After migrating to netweaver 7.5 the copy&paste does not work any more in IE browser when we are in Portal context. It is still working when we execute the webtemplate directly. Does anyone have an idea about the reason for this behaviour or a solution?

Copy&Paste via JavaScript does not work any more in Netweaver Portal 7.5

Very Helpfull

User Rating: Be the first one !
Reviewer Asked on May 26, 2017 in SAP PORTAL.
Add Comment
1 Answer(s)

    Hi Simon,

    Can you check if the document mode is different when you are accessing in Portal context than executing the web template directly.

    Second, please check if you are getting any errors in the console using developer tools in IE.

    This should shed more light on your issue.

    Best Regards,

    Rohit

    Add Comment

    Your Answer

    By posting your answer, you agree to the privacy policy and terms of service.